Skip to main content
← All vulnerabilities
CVE-2026-48069GHSA-99F4-GRH7-6PCQ

@grpc/grps-js: An incoming malformed compressed message can cause a client or server crash

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

@grpc/grps-js implements the core functionality of gRPC purely in JavaScript, without a C++ addon. Prior to 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4, an invalid incoming compressed message can cause a client or server process that uses @grpc/grpc-js to crash. This issue is fixed in versions 1.9.16, 1.10.12, 1.11.4, 1.12.7, 1.13.5, and 1.14.4.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • grpc grpc-node

    fixed in 1.9.16; From 1.10.0 · fixed in 1.10.12; From 1.11.0 · fixed in 1.11.4; From 1.12.0 · fixed in 1.12.7; From 1.13.0 · fixed in 1.13.5; From 1.14.0 · fixed in 1.14.4

  • @grpc/grpc-jsnpm

    fixed in 1.9.16

  • @grpc/grpc-jsnpm

    From 1.10.0 · fixed in 1.10.12

  • @grpc/grpc-jsnpm

    From 1.11.0 · fixed in 1.11.4

  • @grpc/grpc-jsnpm

    From 1.12.0 · fixed in 1.12.7

  • @grpc/grpc-jsnpm

    From 1.13.0 · fixed in 1.13.5

  • @grpc/grpc-jsnpm

    From 1.14.0 · fixed in 1.14.4

References 13

GitHub · grpc/grpc-node