CVE-2026-47761GHSA-VG35-5WQ7-3X7W
TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 5.11.1, 7.9.3, 8.5.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 proof of concept on GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via crafted data-mce-* attributes, which are executed when content is rendered. Impacts users of TinyMCE with the media plugin enabled. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- tinymce tinymce
fixed in 5.11.1; From 6.0.0 · through 6.8.6; From 7.0.0 · fixed in 7.9.3; From 8.0.0 · fixed in 8.5.1
- tinymcenpm
through 5.10.9
- tinymcenpm
From 6.0.0 · fixed in 7.9.3
- tinymcenpm
From 8.0.0 · fixed in 8.5.1
- TinyMCENuGet
through 5.10.9
- TinyMCENuGet
From 6.0.0 · fixed in 7.9.3
- TinyMCENuGet
From 8.0.0 · fixed in 8.5.1
- tinymce/tinymcePackagist
through 5.10.9
- tinymce/tinymcePackagist
From 6.0.0 · fixed in 7.9.3
- tinymce/tinymcePackagist
From 8.0.0 · fixed in 8.5.1