Skip to main content
← All vulnerabilities
CVE-2026-47759GHSA-Q742-QVGC-GC2F

TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 5.11.1, 7.9.3, 8.5.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability via unsanitized data-mce-* attributes (data-mce-href, data-mce-src, data-mce-style). Allows attackers to inject malicious values that override safe attributes during serialization, bypassing validation. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • tinymce tinymce

    fixed in 5.11.1; From 6.0.0 · through 6.8.6; From 7.0.0 · fixed in 7.9.3; From 8.0.0 · fixed in 8.5.1

  • tinymcenpm

    through 5.10.9

  • tinymcenpm

    From 6.0.0 · fixed in 7.9.3

  • tinymcenpm

    From 8.0.0 · fixed in 8.5.1

  • TinyMCENuGet

    through 5.10.9

  • TinyMCENuGet

    From 6.0.0 · fixed in 7.9.3

  • TinyMCENuGet

    From 8.0.0 · fixed in 8.5.1

  • tinymce/tinymcePackagist

    through 5.10.9

  • tinymce/tinymcePackagist

    From 6.0.0 · fixed in 7.9.3

  • tinymce/tinymcePackagist

    From 8.0.0 · fixed in 8.5.1

References 3

GitHub · tinymce/tinymce

tiny.cloud