Skip to main content
← All vulnerabilities
CVE-2026-46588GHSA-5G68-F6XG-VF2R

Apache Camel: CouchDB: Non-Camel-prefixed Exchange headers bypass HeaderFilterStrategy allowing operation override from untrusted input

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.14.8, 4.18.3, 4.21.0
1 proof of concept on GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

Improper Input Validation vulnerability in Apache Camel. This issue affects Apache Camel: through 4.14.7, from 4.15.0 through 4.18.2, from 4.19.0 through 4.20.0. Users are recommended to upgrade to version 4.14.8, 4.18.3, 4.21.0, which fixes the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache Camel

    through 4.14.7; From 4.15.0 · through 4.18.2; From 4.19.0 · through 4.20.0

  • org.apache.camel:camel-couchdbMaven

    From 4.0.0 · fixed in 4.14.8

  • org.apache.camel:camel-couchdbMaven

    From 4.15.0 · fixed in 4.18.3

  • org.apache.camel:camel-couchdbMaven

    From 4.19.0 · fixed in 4.21.0

References 2

camel.apache.org

GitHub · oscerd/CVE-2026-46588