Skip to main content
← All vulnerabilities
CVE-2026-4646GHSA-RMVV-8V8W-RF7XGO-2026-5833

Insufficient input validation in GitHub plugin API causes denial of service

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 11.6.1, 11.5.4, 11.4.5, 10.11.15, 1.0.1-0.20260330164815-c2840e980b3c, and 4 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Mattermost versions 11.6.x <= 11.6.0, 11.5.x <= 11.5.3, 11.4.x <= 11.4.4, 10.11.x <= 10.11.14 fail to validate user-supplied input in API request handlers which allows an authenticated attacker to crash the plugin process via a crafted HTTP request to the PR details endpoint.. Mattermost Advisory ID: MMSA-2026-00638

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Mattermost Mattermost

    From 11.6.0 · through 11.6.0; From 11.5.0 · through 11.5.3; From 11.4.0 · through 11.4.4; From 10.11.0 · through 10.11.14

  • github.com/mattermost/mattermost-serverGo

    From 11.6.0 · fixed in 11.6.1

  • github.com/mattermost/mattermost-serverGo

    From 11.5.0 · fixed in 11.5.4

  • github.com/mattermost/mattermost-serverGo

    From 11.4.0 · fixed in 11.4.5

  • github.com/mattermost/mattermost-serverGo

    From 10.11.0 · fixed in 10.11.15

  • github.com/mattermost/mattermost-plugin-githubGo

    fixed in 1.0.1-0.20260330164815-c2840e980b3c

  • github.com/mattermost/mattermost-serverGo

    From 10.11.0+incompatible · fixed in 10.11.15+incompatible; From 11.4.0+incompatible · fixed in 11.4.5+incompatible; From 11.5.0+incompatible · fixed in 11.5.4+incompatible; From 11.6.0+incompatible · fixed in 11.6.1+incompatible

References 1

mattermost.com