Skip to main content
← All vulnerabilities
CVE-2026-46421GHSA-PVW4-CVR4-97P8

Supply chain compromise via malicious package versions (@cap-js/sqlite, @cap-js/postgres, @cap-js/db-service)

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.3.0, 2.11.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

The SAP Cloud Application Programming Model is a tool for building enterprise-grade cloud applications, and cap-js/cds-dbs is the monorepo for SQL database services for that tool. On April 29, 2026, compromised versions of `@cap-js/sqlite@2.2.2`, `@cap-js/postgres@2.2.2`, and `@cap-js/db-service@2.10.1` were published. The malicious packages harvested credentials and attempted self-propagation. If a compromised version was installed, all credentials accessible on that machine (npm tokens, cloud provider credentials, SSH keys, GitHub PATs) should be considered compromised. User should upgrade to `@cap-js/sqlite` >= 2.4.0, `@cap-js/postgres` >= 2.3.0, `@cap-js/db-service` >= 2.11.0. If a compromised version was ever installed, rotate all affected credentials. No known workarounds are available.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • cap-js @cap-js/sqlite

    2.2.2

  • cap-js @cap-js/postgres

    2.2.2

  • @cap-js/db-service @cap-js/db-service

    2.10.1

  • @cap-js/sqlitenpm

    From 2.2.2 · fixed in 2.3.0

  • @cap-js/postgresnpm

    From 2.2.2 · fixed in 2.3.0

  • @cap-js/db-servicenpm

    From 2.10.1 · fixed in 2.11.0

References 4

GitHub · cap-js/cds-dbs

me.sap.com

sap.com

stepsecurity.io