Skip to main content
← All vulnerabilities
CVE-2026-45133GHSA-C2P3-7M5P-CV8X

Symfony: [Yaml] Harden the parser when handling untrusted input

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 5.4.52, 6.4.40, 7.4.12, 8.0.12
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, when the parser is exposed to attacker-controlled input, deeply nested mappings or sequences cause both the block-level (Parser::parseBlock()) and inline (Inline::parseSequence() / Inline::parseMapping()) parsers to recurse without a depth limit. A crafted document exhausts the PHP stack and crashes the worker. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • symfony symfony

    fixed in 5.4.52; From 6.0.0-BETA1 · fixed in 6.4.40; From 7.0.0-BETA1 · fixed in 7.4.12; From 8.0.0-BETA1 · fixed in 8.0.12

  • symfony/yamlPackagist

    fixed in 5.4.52

  • symfony/symfonyPackagist

    fixed in 5.4.52

  • symfony/symfonyPackagist

    From 6.0.0 · fixed in 6.4.40

  • symfony/symfonyPackagist

    From 7.0.0 · fixed in 7.4.12

  • symfony/symfonyPackagist

    From 8.0.0 · fixed in 8.0.12

  • symfony/yamlPackagist

    From 6.0.0 · fixed in 6.4.40

  • symfony/yamlPackagist

    From 7.0.0 · fixed in 7.4.12

  • symfony/yamlPackagist

    From 8.0.0 · fixed in 8.0.12

References 5

GitHub · symfony/symfony