Skip to main content
← All vulnerabilities
CVE-2026-44911GHSA-QVJ8-GWPM-4X49BIT-NIFI-2026-44911

Apache NiFi: Incorrect Authorization for Configuration Verification Requests

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.10.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Authorization handling for component configuration verification requests in Apache NiFi 1.15.0 through 2.9.0 allows clients with read access to submit proposed configuration properties. The proposed properties override current configuration, enabling users with read access to invoke predefined verification methods with alternative settings. Apache NiFi installations that do not implement different levels of authorization for viewing and modifying component configuration are not subject to this vulnerability. Upgrading to Apache NiFi 2.10.0 is the recommended mitigation, requiring write access to submit configuration verification requests.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • org.apache.nifi:nifi-web-api

    From 1.15.0 · through 2.9.0

  • org.apache.nifi:nifi-web-apiMaven

    From 1.15.0 · fixed in 2.10.0

References 1

lists.apache.org