Skip to main content
← All vulnerabilities
CVE-2026-44580GHSA-GX5P-JG67-6X7H

Next.js: Cross-site scripting in beforeInteractive scripts with untrusted input

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 15.5.16, 16.2.5
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Next.js is a React framework for building full-stack web applications. From 13.0.0 to before 15.5.16 and 16.2.5, applications that use beforeInteractive scripts together with untrusted content can be vulnerable to cross-site scripting. In affected versions, serialized script content was not escaped safely before being embedded into the document, which could allow attacker-controlled input to break out of the intended script context and execute arbitrary JavaScript in a visitor's browser. This vulnerability is fixed in 15.5.16 and 16.2.5.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • vercel next.js

    From 13.0.0 · fixed in 15.5.16; From 16.0.0 · fixed in 16.2.5

  • nextnpm

    From 13.0.0 · fixed in 15.5.16

  • nextnpm

    From 16.0.0 · fixed in 16.2.5

References 1

GitHub · vercel/next.js